
<!doctype html>
<html>
<head>
    <meta charset="utf-8">
    <meta http-equiv="x-ua-compatible" content="ie=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <!-- New Relic Header -->

    
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-NKNF8ZK');</script>

    <title>A-League's Glory bring seasoned Matilda back home</title>
    <link rel="alternate" type="application/rss+xml" title="The Women's Game RSS Feed" href="/rss" />
    <link href='https://fonts.googleapis.com/css?family=Oswald:300,400,500,600,700&display=swap' rel='stylesheet' type='text/css'>
    <link href="https://fonts.googleapis.com/css?family=Open+Sans:400,400i,700,700i" rel="stylesheet">
    <link href="https://fonts.googleapis.com/css?family=Hind+Siliguri:400,500,600,700" rel="stylesheet"> 
    <link href="https://fonts.googleapis.com/css?family=Special+Elite&display=swap" rel="stylesheet">
    <link href="https://fonts.googleapis.com/css?family=Merriweather:400i,700&display=swap" rel="stylesheet"> 
    <link href="https://fonts.googleapis.com/css?family=Bitter|Crete+Round" rel="stylesheet"> 
    <link href="https://fonts.googleapis.com/css?family=Bebas+Neue|Montserrat:400,500&display=swap" rel="stylesheet">
    
    <link rel="apple-touch-icon" sizes="180x180" href="/images/favicons/twg2017/apple-touch-icon.png?v=300818">
    <link rel="icon" type="image/png" href="/images/favicons/twg2017/favicon-32x32.png?v=300818" sizes="32x32">
    <link rel="icon" type="image/png" href="/images/favicons/twg2017/favicon-16x16.png?v=300818" sizes="16x16">
    <link rel="manifest" href="/images/favicons/twg2017/manifest.json?v=300818">
    <link rel="mask-icon" href="/images/favicons/twg2017/safari-pinned-tab.svg?v=300818" color="#008080">
    <meta name="theme-color" content="#008080">

    
    <meta name="description" content="Matildas midfielder Ella Mastrantonio is returning to the A-League, signing with Perth Glory with whom she made her professional debut. &#160;She is the 18th player confirmed for the upcoming season." />

    
    <meta property="og:site_name" content="The Women's Game"> 
    <meta property="og:title" content="A-League's Glory bring seasoned Matilda back home">
    <meta property="og:url" content="https://thewomensgame.com/news/a-leagues-glory-bring-seasoned-matilda-back-home-582540">
    <meta property="og:type" content="article">
    <meta property="og:image" content="https://i.nextmedia.com.au/News/Ella.jpg">
    <meta property="og:image:type" content="image/jpeg" />
    <meta property="og:image:width" content="1024" />
    <meta property="og:image:height" content="576" />    
    <meta property="og:description" content="Matildas midfielder Ella Mastrantonio is returning to the A-League, signing with Perth Glory with whom she made her professional debut. &#160;She is the 18th player confirmed for the upcoming season.">
    
    <meta property="fb:app_id" content="1413667642041391" />

    
    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@thewomensgame">
    <meta name="twitter:creator" content="@thewomensgame">
    <meta name="twitter:title" content="A-League's Glory bring seasoned Matilda back home">
    <meta name="twitter:description" content="Matildas midfielder Ella Mastrantonio is returning to the A-League, signing with Perth Glory with whom she made her professional debut. &#160;She is the 18th player confirmed for the upcoming season.">
    <meta name="twitter:url" content="https://thewomensgame.com/news/a-leagues-glory-bring-seasoned-matilda-back-home-582540">
    
        <meta name="twitter:image" content="https://i.nextmedia.com.au/News/Ella.jpg">
    
    
        
    
    <link rel="canonical" href="https://thewomensgame.com/news/a-leagues-glory-bring-seasoned-matilda-back-home-582540"/>
    
    

    <link rel="stylesheet" type="text/css" href="/styles/css_c61ba1dd0c62169a8fe69df9fd6f373d.css" />  

    <!--[if lt IE 9]>
        <script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.6.2/html5shiv.js"></script>
        <script src="//s3.amazonaws.com/nwapi/nwmatcher/nwmatcher-1.2.5-min.js"></script>
        <script src="//cdn.jsdelivr.net/selectivizr/1.0.3b/selectivizr.js"></script>
        <script src="//cdnjs.cloudflare.com/ajax/libs/respond.js/1.1.0/respond.min.js"></script>
        <script src="/scripts/rem.min.js"></script>
    <![endif]-->

    

    

</head>
<body class="thewomensgame"> 
    
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NKNF8ZK" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <header>
        
        <nav id="is-menu" class="sticky clearfix" style="width:100%;">
            <a href="//www.insidesport.com.au" id="is-menu-logo">&nbsp;</a>  
            
                    <a href="//www.insidesport.com.au/afl">AFL</a>
                
                    <a href="//www.insidesport.com.au/cricket">Cricket</a>
                
                    <a href="//www.ambmag.com.au">Cycling</a>
                
                    <a href="//www.ftbl.com.au">Football</a>
                
                    <a href="//www.golfaustralia.com.au">Golf</a>
                
                    <a href="//www.insidesport.com.au/league">League</a>
                
                    <a href="//www.insidesport.com.au/motorsport">Motorsport</a>
                
                    <a href="//www.insidesport.com.au/union">Union</a>
                
                    <a href="//thewomensgame.com">Women</a>
                
                    <a href="//www.insidesport.com.au/more-sport">More Sport</a>
                
                    <a href="/win">Win</a>
                        
        </nav>
        

        <div id="main-menu" class="sticky clearfix" style="width:100%;">
            <nav class="top-bar top-bar-desktop clearfix thewomensgame">
                <div class="top-bar-secondary">
                    <section>
                        <a id="hlNewsletter" class="tbs-forums" href="/register">Newsletter Signup</a>

                        <a id="hlSubscribe" class="tbs-subscribe" href="https://www.mymagazines.com.au/category/sports-outdoors?utm_source=insidesport&amp;utm_medium=website&amp;utm_campaign=house%20ads" target="_blank">Subscribe</a>
                    </section>
                    <section>
                        <a href="https://twitter.com/thewomensgame" class="social-twitter" title="Follow on Twitter" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
                        <a href="https://www.facebook.com/auswomensgame" class="social-fb" title="Like on Facebook" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
                        <a href="https://www.instagram.com/thewomensgame" class="social-instagram" title="Follow on Instagram" target="_blank"><i class="fa fa-instagram" aria-hidden="true"></i></a>
                        
                    </section>
                    <section>
                    
                        <a href="#" class="search"><i class="fa fa-search fa-lg"></i></a>

                        
                        
                            <a href="/login" class="user-login">
                                <div class="avatar"><i class="fa fa-user-o fa-lg"></i></div>
                            </a>
                            <div id="login-box">
                                <h3 class="section-header">Account Login</h3>
                                <div id="login-error"></div>
                                <label>Username:</label> <input type="text" id="login-username" />
                                <label>Password:</label> <input type="password" id="login-password" />
                                <div class="form-checkbox">
                                    <input id="rememberMe" name="rememberMe" type="checkbox" /><label for="rememberMe">Remember me</label>
                                </div> 
                                <button class="button">login</button>
                                <a href="/forgot" title="Forgot your password?">Forgot your password?</a>
                                <a href="/register">Don't have an account? Register now!</a>
                            </div>
                        
                    </section>
                </div>
                <div class="top-bar-primary">
                    <ul class="dropdown menu" data-dropdown-menu>
                        <li class="top-bar-title"><a href="//thewomensgame.com">&nbsp;</a></li>
                                        
                                <li>
                                    <a href="//thewomensgame.com/2023-world-cup" class="">2023 World Cup</a>
                                    
                                </li>
                                            
                                <li>
                                    <a href="//thewomensgame.com/football" class="">Football</a>
                                    
                                            <ul class="menu">
                                        
                                            <li><a href="//thewomensgame.com/w-league">W-League</a></li>
                                        
                                            <li><a href="//thewomensgame.com/matildas">Matildas</a></li>
                                        
                                            <li><a href="//thewomensgame.com/global-game">Global Game</a></li>
                                        
                                            <li><a href="//thewomensgame.com/aussies-abroad">Aussies Abroad</a></li>
                                        
                                            <li><a href="//thewomensgame.com/young-matildas">Young Matildas and U17s</a></li>
                                        
                                            <li><a href="//thewomensgame.com/podcast">Podcast</a></li>
                                        
                                            </ul>
                                        
                                </li>
                                            
                                <li>
                                    <a href="//thewomensgame.com/womens-golf" class="">Golf</a>
                                    
                                            <ul class="menu">
                                        
                                            <li><a href="//thewomensgame.com/lpga">LPGA Tour</a></li>
                                        
                                            </ul>
                                        
                                </li>
                                            
                                <li>
                                    <a href="//thewomensgame.com/aflw" class="">Aussie Rules</a>
                                    
                                            <ul class="menu">
                                        
                                            <li><a href="//thewomensgame.com/aflw">AFLW</a></li>
                                        
                                            </ul>
                                        
                                </li>
                                            
                                <li>
                                    <a href="//thewomensgame.com/tennis" class="">Tennis</a>
                                    
                                            <ul class="menu">
                                        
                                            <li><a href="//thewomensgame.com/fed-cup">Fed Cup</a></li>
                                        
                                            <li><a href="//thewomensgame.com/grand-slam">Grand Slams</a></li>
                                        
                                            </ul>
                                        
                                </li>
                                            
                                <li>
                                    <a href="//thewomensgame.com/cricket" class="">Cricket</a>
                                    
                                            <ul class="menu">
                                        
                                            <li><a href="//thewomensgame.com/wbbl">WBBL</a></li>
                                        
                                            <li><a href="//thewomensgame.com/southern-stars">Southern Stars</a></li>
                                        
                                            </ul>
                                        
                                </li>
                                            
                                <li>
                                    <a href="//thewomensgame.com/netball" class="">Netball</a>
                                    
                                            <ul class="menu">
                                        
                                            <li><a href="//thewomensgame.com/super-netball">Super Netball</a></li>
                                        
                                            <li><a href="//thewomensgame.com/diamonds">Diamonds</a></li>
                                        
                                            </ul>
                                        
                                </li>
                                            
                                <li>
                                    <a href="//thewomensgame.com/league" class="">League</a>
                                    
                                            <ul class="menu">
                                        
                                            <li><a href="//thewomensgame.com/nrlw">WNRL</a></li>
                                        
                                            <li><a href="//thewomensgame.com/jillaroos">Jillaroos</a></li>
                                        
                                            </ul>
                                        
                                </li>
                                            
                                <li>
                                    <a href="//thewomensgame.com/rugby" class="">Rugby</a>
                                    
                                            <ul class="menu">
                                        
                                            <li><a href="//thewomensgame.com/wallaroos">Wallaroos</a></li>
                                        
                                            <li><a href="//thewomensgame.com/sevens">Sevens</a></li>
                                        
                                            </ul>
                                        
                                </li>
                                            
                                <li>
                                    <a href="//thewomensgame.com/basketball" class="">Basketball</a>
                                    
                                            <ul class="menu">
                                        
                                            <li><a href="//thewomensgame.com/wnbl">WNBL</a></li>
                                        
                                            <li><a href="//thewomensgame.com/opals">Opals</a></li>
                                        
                                            </ul>
                                        
                                </li>
                                            
                                <li>
                                    <a href="//thewomensgame.com/more-sport" class="">More Sport</a>
                                    
                                            <ul class="menu">
                                        
                                            <li><a href="//thewomensgame.com/swimming">Swimming</a></li>
                                        
                                            <li><a href="//thewomensgame.com/surfing">Surfing</a></li>
                                        
                                            <li><a href="//thewomensgame.com/gymnastics">Gymnastics</a></li>
                                        
                                            <li><a href="//thewomensgame.com/athletics">Athletics</a></li>
                                        
                                            </ul>
                                        
                                </li>
                                            
                                <li>
                                    <a href="https://forum.insidesport.com.au/" class="">Forum</a>
                                    
                                </li>
                                            
                                <li>
                                    <a href="/win" class="">Win</a>
                                    
                                </li>
                            
                    </ul>
                </div>
            </nav>
            <div id="search-box">
                <div id="search-box-content">
                    <input type="text" placeholder="Search"><button>&nbsp;</button>
                </div>
            </div>
            

            <nav class="top-bar-mobile mobile-nav clearfix thewomensgame">
                <section class="title-area">
                    <div class="menu-primary" >
                        <button class="c-hamburger c-hamburger--htx">
                            <span></span>
                        </button>
                    </div>
                    <div class="logo top-bar-title"><a href="//thewomensgame.com">&nbsp;</a></div>
                    <div class="menu-secondary">
                        

                            
                            
                                <a class="user-icon"><div id="icon"><i class="fa fa-user-o fa-lg"></i></div></a>
                                <section class="top-bar-user">
                                    <div id="login-box-mobile">
                                        <h3 class="section-header">Account Login</h3>
                                        <div id="login-error-mobile"></div>
                                        <label>Username:</label> <input type="text" id="login-username-mobile" />
                                        <label>Password:</label> <input type="password" id="login-password-mobile" />
                                        <div class="form-checkbox">
                                            <input id="rememberMe-mobile" name="rememberMe" type="checkbox" /><label for="rememberMe-mobile">Remember me</label>
                                        </div> 
                                        <button class="button">login</button>
                                        <a href="/forgot" title="Forgot your password?">Forgot your password?</a>
                                        <a href="/register">Don't have an account? Register now!</a>
                                    </div>
                                </section>
                            
                    </div>
                </section>

                <section class="top-bar-nav">
                    <div class="mobile-nav-search">
                        <input type="text" placeholder="Search">
                    </div>
                    <div class="mobile-nav-container">                        
                                        
                                <a href="//thewomensgame.com/2023-world-cup" class="mobile-nav-item "><span>2023 World Cup</span></a>
                                
                                            
                                <a href="//thewomensgame.com/football" class="mobile-nav-item "><span>Football</span></a>
                                
                                        <div class="mobile-nav-arrow"></div>
                                        <div class="mobile-nav-dropdown ">
                                    
                                            <a href="//thewomensgame.com/w-league" class="mobile-nav-item"><span>W-League</span></a>
                                    
                                            <a href="//thewomensgame.com/matildas" class="mobile-nav-item"><span>Matildas</span></a>
                                    
                                            <a href="//thewomensgame.com/global-game" class="mobile-nav-item"><span>Global Game</span></a>
                                    
                                            <a href="//thewomensgame.com/aussies-abroad" class="mobile-nav-item"><span>Aussies Abroad</span></a>
                                    
                                            <a href="//thewomensgame.com/young-matildas" class="mobile-nav-item"><span>Young Matildas and U17s</span></a>
                                    
                                            <a href="//thewomensgame.com/podcast" class="mobile-nav-item"><span>Podcast</span></a>
                                    
                                        </div>
                                    
                                            
                                <a href="//thewomensgame.com/womens-golf" class="mobile-nav-item "><span>Golf</span></a>
                                
                                        <div class="mobile-nav-arrow"></div>
                                        <div class="mobile-nav-dropdown ">
                                    
                                            <a href="//thewomensgame.com/lpga" class="mobile-nav-item"><span>LPGA Tour</span></a>
                                    
                                        </div>
                                    
                                            
                                <a href="//thewomensgame.com/aflw" class="mobile-nav-item "><span>Aussie Rules</span></a>
                                
                                        <div class="mobile-nav-arrow"></div>
                                        <div class="mobile-nav-dropdown ">
                                    
                                            <a href="//thewomensgame.com/aflw" class="mobile-nav-item"><span>AFLW</span></a>
                                    
                                        </div>
                                    
                                            
                                <a href="//thewomensgame.com/tennis" class="mobile-nav-item "><span>Tennis</span></a>
                                
                                        <div class="mobile-nav-arrow"></div>
                                        <div class="mobile-nav-dropdown ">
                                    
                                            <a href="//thewomensgame.com/fed-cup" class="mobile-nav-item"><span>Fed Cup</span></a>
                                    
                                            <a href="//thewomensgame.com/grand-slam" class="mobile-nav-item"><span>Grand Slams</span></a>
                                    
                                        </div>
                                    
                                            
                                <a href="//thewomensgame.com/cricket" class="mobile-nav-item "><span>Cricket</span></a>
                                
                                        <div class="mobile-nav-arrow"></div>
                                        <div class="mobile-nav-dropdown ">
                                    
                                            <a href="//thewomensgame.com/wbbl" class="mobile-nav-item"><span>WBBL</span></a>
                                    
                                            <a href="//thewomensgame.com/southern-stars" class="mobile-nav-item"><span>Southern Stars</span></a>
                                    
                                        </div>
                                    
                                            
                                <a href="//thewomensgame.com/netball" class="mobile-nav-item "><span>Netball</span></a>
                                
                                        <div class="mobile-nav-arrow"></div>
                                        <div class="mobile-nav-dropdown ">
                                    
                                            <a href="//thewomensgame.com/super-netball" class="mobile-nav-item"><span>Super Netball</span></a>
                                    
                                            <a href="//thewomensgame.com/diamonds" class="mobile-nav-item"><span>Diamonds</span></a>
                                    
                                        </div>
                                    
                                            
                                <a href="//thewomensgame.com/league" class="mobile-nav-item "><span>League</span></a>
                                
                                        <div class="mobile-nav-arrow"></div>
                                        <div class="mobile-nav-dropdown ">
                                    
                                            <a href="//thewomensgame.com/nrlw" class="mobile-nav-item"><span>WNRL</span></a>
                                    
                                            <a href="//thewomensgame.com/jillaroos" class="mobile-nav-item"><span>Jillaroos</span></a>
                                    
                                        </div>
                                    
                                            
                                <a href="//thewomensgame.com/rugby" class="mobile-nav-item "><span>Rugby</span></a>
                                
                                        <div class="mobile-nav-arrow"></div>
                                        <div class="mobile-nav-dropdown ">
                                    
                                            <a href="//thewomensgame.com/wallaroos" class="mobile-nav-item"><span>Wallaroos</span></a>
                                    
                                            <a href="//thewomensgame.com/sevens" class="mobile-nav-item"><span>Sevens</span></a>
                                    
                                        </div>
                                    
                                            
                                <a href="//thewomensgame.com/basketball" class="mobile-nav-item "><span>Basketball</span></a>
                                
                                        <div class="mobile-nav-arrow"></div>
                                        <div class="mobile-nav-dropdown ">
                                    
                                            <a href="//thewomensgame.com/wnbl" class="mobile-nav-item"><span>WNBL</span></a>
                                    
                                            <a href="//thewomensgame.com/opals" class="mobile-nav-item"><span>Opals</span></a>
                                    
                                        </div>
                                    
                                            
                                <a href="//thewomensgame.com/more-sport" class="mobile-nav-item "><span>More Sport</span></a>
                                
                                        <div class="mobile-nav-arrow"></div>
                                        <div class="mobile-nav-dropdown ">
                                    
                                            <a href="//thewomensgame.com/swimming" class="mobile-nav-item"><span>Swimming</span></a>
                                    
                                            <a href="//thewomensgame.com/surfing" class="mobile-nav-item"><span>Surfing</span></a>
                                    
                                            <a href="//thewomensgame.com/gymnastics" class="mobile-nav-item"><span>Gymnastics</span></a>
                                    
                                            <a href="//thewomensgame.com/athletics" class="mobile-nav-item"><span>Athletics</span></a>
                                    
                                        </div>
                                    
                                            
                                <a href="https://forum.insidesport.com.au/" class="mobile-nav-item "><span>Forum</span></a>
                                
                                            
                                <a href="/win" class="mobile-nav-item "><span>Win</span></a>
                                
                            
                        <a href="//www.insidesport.com.au" class="mobile-nav-item"><span>+ All Sports</span></a>

                        <section>
                            <a id="hlNewsletterMobile" class="tbs-forums" href="/register">Newsletter Signup</a>

                            <a id="hlSubscribeMobile" class="tbs-subscribe" href="https://www.mymagazines.com.au/category/sports-outdoors?utm_source=insidesport&amp;utm_medium=website&amp;utm_campaign=house%20ads" target="_blank">Subscribe</a>
                            <div class="clearfix"></div> 
                        </section>

                        <section class="mobile-nav-follow">
                            <a class="follow-twitter" href="https://twitter.com/thewomensgame" target="_blank"></a>
                            <a class="follow-facebook" href="https://www.facebook.com/auswomensgame" target="_blank"></a>
                            <a class="follow-instagram" href="https://www.instagram.com/thewomensgame" target="_blank"></a> 
                            
                        </section>
                        
                        <div class="clearfix">&nbsp;</div>                 
                    </div> 
                </section>
            </nav>
        </div>
    </header>

    <div id="skin">
        <div id="div-gpt-ad-leader-skin"></div>

        <div class="content-wrapper" id="content-wrapper">
            
    
    
        <article itemscope itemtype="http://schema.org/NewsArticle">

            <header class="row collapse noimage" style="">                
                <div class="article-header-container">
                    <div class="article-header-content">
                        

                         

                        
                            <div class="article-img" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
                                <picture>
                                    <source srcset="https://i.nextmedia.com.au/Utils/ImageResizerWebP.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fElla.jpg&amp;h=600&amp;w=850&amp;c=0&amp;s=1" width="850" height="600" alt="A-League&#39;s Glory bring seasoned Matilda back home" title="A-League&#39;s Glory bring seasoned Matilda back home"  type="image/webp">
                                    <source srcset="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fElla.jpg&amp;h=600&amp;w=850&amp;c=0&amp;s=1" width="850" height="600" alt="A-League&#39;s Glory bring seasoned Matilda back home" title="A-League&#39;s Glory bring seasoned Matilda back home" type="image/jpeg">
                                    <img src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fElla.jpg&amp;h=600&amp;w=850&amp;c=0&amp;s=1" width="850" height="600" alt="A-League&#39;s Glory bring seasoned Matilda back home" title="A-League&#39;s Glory bring seasoned Matilda back home">
                                </picture>
                            </div>      
                            
                            
                        <div class="article-header-titleintro">
                            <h1 itemprop="headline" class="headline">A-League's Glory bring seasoned Matilda back home</h1>                        
                            
                            <div id="article-details">
                                 
                                
                                        By
                                        <span class="article-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
                                    
                                        <a href="/author/catherine-paquette-1470482">
                                            <span itemprop="name">Catherine Paquette</span>
                                        </a>
                                    
                                        </span>
                                        
                                
                                <span class="article-date"><span id="ContentPlaceHolder1_lbDateFrom" itemprop="datePublished" content="2022-07-12T16:38">Jul 12 2022 4:38PM</span></span>
                            </div>
                        </div>
                    </div>
                </div>

                <div id="article-author-mobile" class="row collapse">
                    <div class="small-6 columns">
                        
                                By
                                <span class="article-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
                            
                                <a href="/author/catherine-paquette-1470482">
                                    <span itemprop="name">Catherine Paquette</span>
                                </a>
                            
                                </span>
                                
                        
                        <div class="article-date"><span id="ContentPlaceHolder1_lbDateFromMobile" itemprop="datePublished" content="2022-07-12T16:38">Jul 12 2022 4:38PM</span></div>
                    </div>
                </div>                
            </header>

            <div class="row article-content" id="main-content">
                <div id="div-gpt-ad-leader-top" class="ad-leaderboard"></div>

                <div class="small-12 columns" id="article-wrapper">
                    
                    <div id="article-primary">
                        <div id="article-primary-content">
                            <h4 id="article-intro" itemprop="description">Perth Glory have continued to build ahead of the upcoming A-League season, with the recent recruitment of former player Ella Mastrantonio. </h4>
                            
                         
                            <div class="article-body" itemprop="articleBody">
                                <p>Matildas midfielder Ella Mastrantonio is returning to the A-League, signing with Perth Glory with whom she made her professional debut.  She is the 18th player confirmed for the upcoming season.</p>
<h3>Perth Glory Signings</h3>
<ul>
<li>Ella Mastrantonio has signed with Perth Glory.</li>
<li>The Matildas player returns to the A-League after two season abroad.</li>
<li>She is one of 18 players committed to Glory for 2022-23.</li>
</ul>
<p><strong>More Australian football news can be found on <a href="https://www.ftbl.com.au/">FTBL.</a></strong></p>
                                
                                <div class="dugout-video dugout-embed-eyJrZXkiOiIiLCJwIjoibmV4dC1tZWRpYSIsInBsIjoiNjJyYjh1YUUifQ==" style="margin-bottom:1.5rem;"></div>
                                <script type="text/javascript" src="https://embed.dugout.com/v3.1/next-media.js"></script>
                            
<p>It will be a homecoming for the Fremantle born Ella Mastrantonio, who is about to start her fourth stint with Perth.  The 30-year old first made her debut with the A-League side during the 2009-10 season and would go onto win the Championship with Glory in 2013-14 during her second spell with the club.</p>
<p>Mastrantonio also played for Melbourne Victory and Western Sydney Wanderers during her first nine seasons of professional play in Australia.   In 2020-21 she headed abroad and played in the FA WSL for Bristol City.  The Serie A then came calling last year with Mastrantonio first playing with Lazio before moving to Pomigliano mid-season.  </p>
<div class="ArticleImage "><img src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fgettyimages-1337431104-594x594.jpg&c=0" /></div>
<p>In total, she has made more than 125 professional club appearances and has featured seven times for the Matildas, most recently playing for Australia last year.</p>
<p><span>"I’m very happy to have signed back at home with Perth Glory," said Mastrantonio <a href="https://perthglory.com.au/news/experienced-matildas-midfielder-returns-for-more-glory">upon signing</a>. </span><br /><br /><span>"Speaking with Alex Epakis (Perth's head coach) and people around the club, there is a very good vision and plan for the women’s football department which I’m excited to be a part of.</span><br /><br /><span>"Coupled with the announcement of the season being extended and more teams coming in, the club is heading in the right direction, especially in the lead up to the Women’s World Cup next year."</span></p>
<p><span>Her signing raises the number of players committed to Perth Glory for the upcoming season to 18. </span></p>
<p><span>Morgan Aquino, Kim Carroll, Alana Jancevski, Hana Lowry, Ella Mastrantonio, Claudia Mihocic, Tijan McKenna, Sofia Sakalis, Natasha Rigby, Cyera Hintzen, Liz Anton, Aideen Keane, Sarah Cain, Demi Koulizakis, Sadie Lawrence and Susan Phonsongkham are all signed for the upcoming campaign.</span></p>
<p><span>Youngsters Abbey Green and Isabella Wallhead signed two year <a href="https://perthglory.com.au/news/liberty-a-league-young-guns-pen-two-year-deals">deals</a> which will keep them with Perth until the end of the 2023-24 season.</span></p>
<p><span><div class="row collapse article-embed-container article-582512">
                                        <div class="small-4 large-3 columns article-list-img">
                                            <a href="//thewomensgame.com/news/matildas-stalwart-departs-arsenal-linked-to-psg-582512">
                                                <img src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2f20220712120259_Lydia_Williams.jpg&amp;h=200&amp;w=300&amp;c=1&amp;s=1">
                                            </a>
                                        </div>
                                        <div class="small-8 large-9 columns article-list-content">
                                            <span class="title">PLUS...</span>
                                            <a href="//thewomensgame.com/news/matildas-stalwart-departs-arsenal-linked-to-psg-582512">
                                                <h2 class="article-list-title">Matildas stalwart departs Arsenal, linked to PSG</h2>
                                                <div class="cat-article-intro">Matildas goalkeeper Lydia Williams has departed FA Women's Super League side Arsenal FC.</div>
                                            </a>
                                        </div>
                                    </div></span></p>
<p><span><div class="row collapse article-embed-container article-582134">
                                        <div class="small-4 large-3 columns article-list-img">
                                            <a href="//thewomensgame.com/news/unbelievable-fowlers-manchester-city-move-will-help-matildas-582134">
                                                <img src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fGettyImages-1348210531_Cropped-min.jpg&amp;h=200&amp;w=300&amp;c=1&amp;s=1">
                                            </a>
                                        </div>
                                        <div class="small-8 large-9 columns article-list-content">
                                            <span class="title">PLUS...</span>
                                            <a href="//thewomensgame.com/news/unbelievable-fowlers-manchester-city-move-will-help-matildas-582134">
                                                <h2 class="article-list-title">'Unbelievable' Fowler's Manchester City move will help Matildas</h2>
                                                <div class="cat-article-intro">Matildas prodigy Mary Fowler is eyeing trophies and developing into a top player at Manchester City and Australia is poised to reap the rewards of her big move.</div>
                                            </a>
                                        </div>
                                    </div></span></p>
<p><span><strong>More news can be found <a href="https://10play.com.au/a-league/articles/a-league-2021-fixtures/tpa211013visyn">here.</a></strong></span></p>
                            </div>

                            

                            

                            <div class="article-social bottom">
                                <h3 class="sec-section-header">SHARE</h3>  
                                <a target="_blank" href="https://twitter.com/intent/tweet?text=A-League's Glory bring seasoned Matilda back home&amp;related=&amp;url=https%3a%2f%2fthewomensgame.com%2fnews%2fa-leagues-glory-bring-seasoned-matilda-back-home-582540%3Futm_source=desktop_bottom%26utm_medium=twitter%26utm_campaign=share" class="twitter shareurl" id="twitter-share"><i class="fa fa-twitter" aria-hidden="true"></i></a>
                                <a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fthewomensgame.com%2fnews%2fa-leagues-glory-bring-seasoned-matilda-back-home-582540%3Futm_source=desktop_bottom%26utm_medium=facebook%26utm_campaign=share" class="facebook shareurl" id="facebook-share"><i class="fa fa-facebook"  aria-hidden="true"></i></a>
                                <a href="mailto:?subject=FTBL: A-League's Glory bring seasoned Matilda back home&amp;body=Check out this great article I read on FTBL:%0D%0A%0D%0AA-League's Glory bring seasoned Matilda back home%0D%0A%0D%0Ahttps%3a%2f%2fthewomensgame.com%2fnews%2fa-leagues-glory-bring-seasoned-matilda-back-home-582540%3Futm_source=desktop_bottom%26utm_medium=email%26utm_campaign=share" class="email"><i class="fa fa-envelope" aria-hidden="true"></i></a>
                            </div>

                            

                            <div class="article-src">
                                <b> Copyright &#169;The Women's Game</b> All rights reserved. 
                            </div>

                            
                            <div class="article-tags">
                                <div>Tags: &nbsp; </div><a href="/abbey-green">abbey green</a><a href="/a-league">a-league</a><a href="/a-league-women">a-league women</a><a href="/cyera-hintzen">cyera hintzen</a><a href="/ella-mastrantonio">ella mastrantonio</a><a href="/isabella-wallhead">isabella wallhead</a><a href="/kim-carroll">kim carroll</a><a href="/matildas">matildas</a><a href="/matildas-abroad">matildas abroad</a><a href="/natasha-rigby">natasha rigby</a><a href="/perth-glory">perth glory</a><a href="/w-league">w-league</a>
                            </div>
                            

                            
							<div class="OUTBRAIN" data-src="https://thewomensgame.com/news/a-leagues-glory-bring-seasoned-matilda-back-home-582540" data-widget-id="GS_1" data-ob-template="InsideSport"></div>
                            <div class="OUTBRAIN" data-src="https://thewomensgame.com/news/a-leagues-glory-bring-seasoned-matilda-back-home-582540" data-widget-id="AR_1" data-ob-template="InsideSport"></div>
							<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
                            

                            
                            
                            <div id="div-gpt-ad-inread"></div>
                            

                        </div>


                        <div id="article-secondary">
                            <div data-sticky-container>
                                <div class="sticky clearfix" data-sticky  data-top-anchor="article-secondary" data-btm-anchor="article-primary:bottom" data-sticky-on="medium" data-margin-top="10" data-check-every="0">
                                    <div class="article-social">
                                        <h3 class="sec-section-header">SHARE</h3>                                        
                                        <a target="_blank" href="https://twitter.com/intent/tweet?text=A-League's Glory bring seasoned Matilda back home&amp;related=&amp;url=https%3a%2f%2fthewomensgame.com%2fnews%2fa-leagues-glory-bring-seasoned-matilda-back-home-582540%3Futm_source=desktop_left%26utm_medium=twitter%26utm_campaign=share" class="twitter shareurl" id="twitter-share">&nbsp;</a>
                                        <a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fthewomensgame.com%2fnews%2fa-leagues-glory-bring-seasoned-matilda-back-home-582540%3Futm_source=desktop_left%26utm_medium=facebook%26utm_campaign=share" class="facebook shareurl" id="facebook-share">&nbsp;</a>
                                        <a href="mailto:?subject=FTBL: A-League's Glory bring seasoned Matilda back home&amp;body=Check out this great article I read on FTBL:%0D%0A%0D%0AA-League's Glory bring seasoned Matilda back home%0D%0A%0D%0Ahttps%3a%2f%2fthewomensgame.com%2fnews%2fa-leagues-glory-bring-seasoned-matilda-back-home-582540%3Futm_source=desktop_left%26utm_medium=email%26utm_campaign=share" class="email">&nbsp;</a>
                                    </div>
                                
                                </div>
                            </div>
                        </div>

                    </div>
                    

                    <div id="article-tertiary">
                        



<div id="div-gpt-ad-mrec-sto" class="ad-mrec"></div>


        <div class="article-list-sec-container">
            <h3 class="sec-section-header">Related Articles</h3>
    
            <a href="//thewomensgame.com/news/four-potential-young-matildas-were-hoping-to-see-at-the-u-20-world-cup-579600" class="row collapse article-list-container">
                <div class="small-4 large-6 columns article-list-img">
                    <img alt="Four potential Young Matildas we&amp;#8217;re hoping to see at the U-20 World Cup" width="150" height="84" src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fJessika_Nash_Cropped.jpg&amp;h=172&amp;w=306&amp;c=1&amp;s=1">
                </div>
                <div class="small-8 large-6 columns article-list-content">                                            
                    <h2 class="article-list-title">Four potential Young Matildas we&#8217;re hoping to see at the U-20 World Cup</h2>
                </div>
            </a>
    
            <a href="//thewomensgame.com/news/matilda-siemsen-set-to-make-swedish-switch-577975" class="row collapse article-list-container">
                <div class="small-4 large-6 columns article-list-img">
                    <img alt="Matilda Siemsen set to make Swedish switch" width="150" height="84" src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fgettyimages-1358367290-594x594_Cropped-3.jpg&amp;h=172&amp;w=306&amp;c=1&amp;s=1">
                </div>
                <div class="small-8 large-6 columns article-list-content">                                            
                    <h2 class="article-list-title">Matilda Siemsen set to make Swedish switch</h2>
                </div>
            </a>
    
            <a href="//thewomensgame.com/news/tenacious-victory-scrape-into-a-league-finals-576905" class="row collapse article-list-container">
                <div class="small-4 large-6 columns article-list-img">
                    <img alt="Tenacious Victory scrape into A-League finals" width="150" height="84" src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fGettyImages-1378569741_Cropped.jpg&amp;h=172&amp;w=306&amp;c=1&amp;s=1">
                </div>
                <div class="small-8 large-6 columns article-list-content">                                            
                    <h2 class="article-list-title">Tenacious Victory scrape into A-League finals</h2>
                </div>
            </a>
    
        </div>
    



   

<div class="article-list-sec-container">
    <h3 class="sec-section-header">Latest News</h3>
    
            <a href="//thewomensgame.com/news/a-leagues-glory-bring-seasoned-matilda-back-home-582540" class="row collapse article-list-container">
                <div class="small-3 large-6 columns article-list-img">
                <picture>
                    <source srcset="https://i.nextmedia.com.au/Utils/ImageResizerWebP.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fElla.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="A-League's Glory bring seasoned Matilda back home" type="image/webp" >
                    <source srcset="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fElla.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="A-League's Glory bring seasoned Matilda back home" type="image/jpeg" >
                    <img src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fElla.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1"   width="225"  height="115" alt="A-League's Glory bring seasoned Matilda back home" >
                </picture>
                </div>
                <div class="small-9 large-6 columns article-list-content">                                            
                    <h2 class="article-list-title">A-League's Glory bring seasoned Matilda back home</h2>
                    <div class="article-list-date">12 Jul 2022</div>
                </div>
            </a>
        
            <a href="//www.golfaustralia.com.au/news/so-called-expert-open-championship-tips-582544" class="row collapse article-list-container">
                <div class="small-3 large-6 columns article-list-img">
                <picture>
                    <source srcset="https://i.nextmedia.com.au/Utils/ImageResizerWebP.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2f20220712050054_tips.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="So-called expert Open Championship tips" type="image/webp" >
                    <source srcset="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2f20220712050054_tips.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="So-called expert Open Championship tips" type="image/jpeg" >
                    <img src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2f20220712050054_tips.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1"   width="225"  height="115" alt="So-called expert Open Championship tips" >
                </picture>
                </div>
                <div class="small-9 large-6 columns article-list-content">                                            
                    <h2 class="article-list-title">So-called expert Open Championship tips</h2>
                    <div class="article-list-date">12 Jul 2022</div>
                </div>
            </a>
        
            <a href="//www.golfaustralia.com.au/news/the-preview-dow-great-lakes-bay-invitational-582533" class="row collapse article-list-container">
                <div class="small-3 large-6 columns article-list-img">
                <picture>
                    <source srcset="https://i.nextmedia.com.au/Utils/ImageResizerWebP.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2f20220712035212_nelly-korda.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="The Preview: Dow Great Lakes Bay Invitational" type="image/webp" >
                    <source srcset="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2f20220712035212_nelly-korda.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="The Preview: Dow Great Lakes Bay Invitational" type="image/jpeg" >
                    <img src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2f20220712035212_nelly-korda.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1"   width="225"  height="115" alt="The Preview: Dow Great Lakes Bay Invitational" >
                </picture>
                </div>
                <div class="small-9 large-6 columns article-list-content">                                            
                    <h2 class="article-list-title">The Preview: Dow Great Lakes Bay Invitational</h2>
                    <div class="article-list-date">12 Jul 2022</div>
                </div>
            </a>
             
</div>

<div id="div-gpt-ad-mrec-sto2" class="ad-mrec"></div>
       

    <div class="article-list-sec-container">
        <h3 class="sec-section-header">Most Read</h3>
        
                <a href="//www.ftbl.com.au/news/london-calling-a-league-rookie-lands-chelsea-fc-chance-582301" class="row collapse article-list-container">
                    <div class="small-3 large-6 columns article-list-img">
                        <picture>
                            <source srcset="https://i.nextmedia.com.au/Utils/ImageResizerWebP.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fYull.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="London calling: A-League rookie lands Chelsea FC chance" type="image/webp" >
                            <source srcset="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fYull.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="London calling: A-League rookie lands Chelsea FC chance" type="image/jpeg" >
                            <img src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fYull.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1"   width="225"  height="115" alt="London calling: A-League rookie lands Chelsea FC chance" >
                        </picture>
                    </div>
                    <div class="small-9 large-6 columns article-list-content">                                            
                        <h2 class="article-list-title">London calling: A-League rookie lands Chelsea FC chance</h2>
                        <div class="article-list-date">7 Jul 2022</div>
                    </div>
                </a>
            
                <a href="//www.ftbl.com.au/news/talks-at-delicate-stage-spanish-legend-on-cusp-of-a-league-entrance-582429" class="row collapse article-list-container">
                    <div class="small-3 large-6 columns article-list-img">
                        <picture>
                            <source srcset="https://i.nextmedia.com.au/Utils/ImageResizerWebP.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fGettyImages-1331348387_Cropped-min.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="Talks at 'delicate' stage: Spanish legend on cusp of A-League entrance" type="image/webp" >
                            <source srcset="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fGettyImages-1331348387_Cropped-min.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="Talks at 'delicate' stage: Spanish legend on cusp of A-League entrance" type="image/jpeg" >
                            <img src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fGettyImages-1331348387_Cropped-min.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1"   width="225"  height="115" alt="Talks at 'delicate' stage: Spanish legend on cusp of A-League entrance" >
                        </picture>
                    </div>
                    <div class="small-9 large-6 columns article-list-content">                                            
                        <h2 class="article-list-title">Talks at 'delicate' stage: Spanish legend on cusp of A-League entrance</h2>
                        <div class="article-list-date">11 Jul 2022</div>
                    </div>
                </a>
            
                <a href="//www.ftbl.com.au/news/premier-league-giants-replace-rangers-for-anges-homecoming-tour-582269" class="row collapse article-list-container">
                    <div class="small-3 large-6 columns article-list-img">
                        <picture>
                            <source srcset="https://i.nextmedia.com.au/Utils/ImageResizerWebP.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2f20220707062725_GettyImages-1347494108_Cropped.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="Premier League giants replace Rangers for Ange's Homecoming Tour" type="image/webp" >
                            <source srcset="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2f20220707062725_GettyImages-1347494108_Cropped.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="Premier League giants replace Rangers for Ange's Homecoming Tour" type="image/jpeg" >
                            <img src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2f20220707062725_GettyImages-1347494108_Cropped.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1"   width="225"  height="115" alt="Premier League giants replace Rangers for Ange's Homecoming Tour" >
                        </picture>
                    </div>
                    <div class="small-9 large-6 columns article-list-content">                                            
                        <h2 class="article-list-title">Premier League giants replace Rangers for Ange's Homecoming Tour</h2>
                        <div class="article-list-date">7 Jul 2022</div>
                    </div>
                </a>
            
                <a href="//thewomensgame.com/news/former-socceroo-captain-on-st-george-saints-transformation-582213" class="row collapse article-list-container">
                    <div class="small-3 large-6 columns article-list-img">
                        <picture>
                            <source srcset="https://i.nextmedia.com.au/Utils/ImageResizerWebP.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fMark_Milligan_3_Cropped-min.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="Former Socceroo captain on St George Saints transformation" type="image/webp" >
                            <source srcset="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fMark_Milligan_3_Cropped-min.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1" alt="Former Socceroo captain on St George Saints transformation" type="image/jpeg" >
                            <img src="https://i.nextmedia.com.au/Utils/ImageResizer.ashx?n=https%3a%2f%2fi.nextmedia.com.au%2fNews%2fMark_Milligan_3_Cropped-min.jpg&amp;h=115&amp;w=225&amp;c=1&amp;s=1"   width="225"  height="115" alt="Former Socceroo captain on St George Saints transformation" >
                        </picture>
                    </div>
                    <div class="small-9 large-6 columns article-list-content">                                            
                        <h2 class="article-list-title">Former Socceroo captain on St George Saints transformation</h2>
                        <div class="article-list-date">11 Jul 2022</div>
                    </div>
                </a>
                        
    </div>


<div id="div-gpt-ad-mrec-sto3" class="ad-mrec"></div>
                    </div>
                    <div class="row">
                        <div class="small-12 columns">
                            
                        </div>
                    </div>
                </div>
            </div>

            <div class="share-bar-mobile news"> 
                <button type="button">Share</button>  
                <div class="article-share-mobile">
                    <a class="share-twitter" title="Share on Twitter" href="https://twitter.com/intent/tweet?text=A-League's Glory bring seasoned Matilda back home&amp;related=&amp;url=https%3a%2f%2fthewomensgame.com%2fnews%2fa-leagues-glory-bring-seasoned-matilda-back-home-582540%3Futm_source=mobile%26utm_medium=twitter%26utm_campaign=share" target="_blank"><img src="/images/mobile-share-twitter.png" border="0" alt="Share on Twitter" /></a>
                    <a class="share-facebook" title="Share on Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fthewomensgame.com%2fnews%2fa-leagues-glory-bring-seasoned-matilda-back-home-582540%3Futm_source=mobile%26utm_medium=facebook%26utm_campaign=share" target="_blank"><img src="/images/mobile-share-facebook.png" border="0" alt="Share on Facebook" /></a>
                    <a class="share-whatsapp" title="Share on WhatsApp" href="whatsapp://send?text=A-League's Glory bring seasoned Matilda back home%0D%0A%0D%0Ahttps%3a%2f%2fthewomensgame.com%2fnews%2fa-leagues-glory-bring-seasoned-matilda-back-home-582540%3Futm_source=mobile%26utm_medium=whatsapp%26utm_campaign=share"><img src="/images/mobile-share-whatsapp.png" border="0" alt="Share on Whatsapp" /></a>
                    <a class="share-messenger" title="Share on Messenger" href="fb-messenger://share/?link=https%3a%2f%2fthewomensgame.com%2fnews%2fa-leagues-glory-bring-seasoned-matilda-back-home-582540%3Futm_source=mobile%26utm_medium=messenger%26utm_campaign=share&app_id=267811213"><img src="/images/mobile-share-messenger.png" border="0" alt="Share on Whatsapp" /></a>
                    <a class="share-email" title="Email A Friend" href="mailto:?subject=FTBL: A-League's Glory bring seasoned Matilda back home&amp;body=Check out this great article I read on FTBL:%0D%0A%0D%0AA-League's Glory bring seasoned Matilda back home%0D%0A%0D%0Ahttps%3a%2f%2fthewomensgame.com%2fnews%2fa-leagues-glory-bring-seasoned-matilda-back-home-582540%3Futm_source=mobile%26utm_medium=email%26utm_campaign=share"><img src="/images/mobile-share-email.png" border="0" alt="Email A Friend" /></a>
                </div>
            </div>

            <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
                <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
                    <meta itemprop="url" content="https://thewomensgame.com/images/the-womens-game-logo.png">
                    <meta itemprop="width" content="441">
                    <meta itemprop="height" content="220">
                </div>
                <meta itemprop="name" content="The Women's Game">
            </div>
        </article>
    
    <script id="comment-template" type="text/template">
        <div class="article-comment-item" id="commentid-{postid}">
            <div class="clearfix article-comment-wrapper">
            <div class="clearfix article-comment">
                <div class="article-comment-details">
                    <div class="article-comment-user">
                        <span>{username}</span>                           
                        <div class="article-comment-userimg"><img src="/images/spacer.gif" style="height:48px;width:48px;" alt="{altusername}"></div>
                    </div>
                    <div class="article-comment-date">
                        {datestamp}
                    </div>
                </div>
                <div class="article-comment-body">
                    {message}
                </div>
            </div>
            </div>
            <div class="expand-comment-container">
                <button style="display:none;" class="expand-comment button">READ MORE</button>
            </div>            
        </div>
    </script>


            <div id="is-data-store"
                data-sharetoken="Uy2S8XoKe0SrVqUYY/OWo7jLoH+NqbKLCHRspt1KgJHhuqBrKiWhoDwHBuax1hMLkOnC2LwGP8kl7NEnqf+0guoIu8auPTWEGPH9sS1CsYbssIdifLQGWz/90AcUTxn/"
                data-articleid="582540"
                data-adcategories="[&quot;thewomensgame&quot;,&quot;football&quot;]"
                data-adkeywords="[&quot;abbey green&quot;,&quot;a-league&quot;,&quot;a-league women&quot;,&quot;cyera hintzen&quot;,&quot;ella mastrantonio&quot;,&quot;isabella wallhead&quot;,&quot;kim carroll&quot;,&quot;matildas&quot;,&quot;matildas abroad&quot;,&quot;natasha rigby&quot;,&quot;perth glory&quot;,&quot;w-league&quot;]"
                data-adsection="news"
                data-adshow="True"
                data-gasitesection="News"
                data-gasitecategory="The Women&#39;s Game"
                data-gasitesubcategory=""
                data-gakeywords="|abbey green|a-league|a-league women|cyera hintzen|ella mastrantonio|isabella wallhead|kim carroll|matildas|matildas abroad|natasha rigby|perth glory|w-league|"
                data-comment-hash="y2xacbB9BXxSzvT4GVYeaw=="
                data-fb="1413667642041391">
            </div>
            <div class="clearfix"></div>
            <div class="row ad-footerboard-container">
                <div id="div-gpt-ad-footer" class="ad-footerboard"></div>
            </div>
        </div>
    </div>
    <footer>
        <div class="row">
            <div class="small-12 medium-4 columns footer-copy" style="height:60px;">
                
                    <a href="https://www.nextmedia.com.au/" target="_blank" class="nm-logo"><img src="/images/logo_nextmedia.png" alt="nextmedia" width="75" height="14" /></a>&nbsp; &copy; 2022 nextmedia Pty Ltd.
                
                
            </div>
            <div class="small-12 medium-8 columns footer-links">
                <a id="hlSubscribeFooter" href="https://www.mymagazines.com.au/category/sports-outdoors?utm_source=insidesport&amp;utm_medium=website&amp;utm_campaign=house%20ads" target="_blank">Subscribe</a> | 
                <a href="/rss">RSS</a> | 
                <a href="/sitemap">Sitemap</a> | 
                <a id="hlPrivacy" href="https://www.nextmedia.com.au/privacy-policy/" target="_blank">Privacy Statement</a> | 
                <a id="hlTerms" href="https://www.nextmedia.com.au/terms-conditions/" target="_blank">Terms and Conditions</a> | 
                <a href="https://www.nextmedia.com.au/brand/the-womens-game/" target="_blank">Contact Us</a> | 
                <a href="https://www.nextmedia.com.au/brand/the-womens-game/" target="_blank">Advertise</a>
                
                    <br /><br /><img src="/images/twg-by-insidesport.png" alt="The Women's Game brought to you by Inside Sport" />
                
                <div class="footer-powered-by">
                    <span>Powered By</span>
                    <a href="https://www.interactive.com.au" target="_blank"><img src="/images/interactive-logo.png" alt="Powered by Interactive" width="130" height="24"></a>
                </div>
            </div>
        </div>
        <div id="otp">
            <div id="countdown" class="close"></div>
            <div id="div-gpt-ad-interstitial"></div>
        </div>
        <div class="mask"> </div>
        <div id="div-gpt-ad-skin"></div>
    </footer>
    <div class="gallery-mask"></div>
    <img id="imgPixelTrack" src="/t.ashx?u=&amp;c=582540&amp;s=60&amp;r=&amp;n=%2fArticlePage.aspx&amp;q=id%3d582540%26type%3dnews%26utm_source%3dfeed%26utm_medium%3drss%26utm_campaign%3dftbl%2brss" alt="" style="display:none;" />
    <div id="fb-root"></div>
    <script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.2/jquery.min.js"></script>
    <script src="https://cdnjs.cloudflare.com/ajax/libs/foundation/6.2.3/foundation.min.js"></script>
    <script src="https://securepubads.g.doubleclick.net/tag/js/gpt.js" async="async"></script>
    <script src="/scripts/gdpr.js" data-cookiepolicy="https://www.nextmedia.com.au/cookie-policy"></script>
    <script src="/scripts/js_8e47f58a5f095d30464ba91dc19fc6db.js"></script>
    
     

    <!--[if lt IE 9]>    
        <link href="/styles/ie8.css" rel="stylesheet" type="text/css">
    <![endif]-->

<!-- ver:  -->

</body>
</html>
